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The information in this document is current as of August, 2000. The information is subject to 
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data books, etc., for the most up-to-date specifications of NEC semiconductor products.  Not all 
products and/or types are available in every country.  Please check with an NEC sales representative 
for availability and additional information.
No part of this document may be copied or reproduced in any form or by any means without prior       
written consent of NEC.  NEC assumes no responsibility for any errors that may appear in this document.
NEC does not assume any liability for infringement of patents, copyrights or other intellectual property rights of 
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liability arising from the use of such products.  No license, express, implied or otherwise, is granted under any 
patents, copyrights or other intellectual property rights of NEC or others.
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NEC semiconductor products are classified into the following three quality grades:
"Standard", "Special" and "Specific".  The "Specific" quality grade applies only to semiconductor products 
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recommended applications of a semiconductor product depend on its quality grade, as indicated below.  
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The quality grade of NEC semiconductor products is "Standard" unless otherwise expressly specified in NEC's 
data sheets or data books, etc.  If customers wish to use NEC semiconductor products in applications not 
intended by NEC, they must contact an NEC sales representative in advance to determine NEC's willingness 
to support a given application.
(Note)
(1) "NEC" as used in this statement means NEC Corporation and also includes its majority-owned subsidiaries.
(2) "NEC semiconductor products" means any semiconductor product developed or manufactured by or for

NEC (as defined above).
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PREFACE

Target Readers This manual is intended for users who wish to design and develop application systems

using the VR4100 Series, VR4300 Series, and VR5432.

Purpose This manual is intended for users to understand the general functions and basic

operations of the AZ4000.

Organization This manual contains the following information:

• Overview

 Creation of AZ monitor

• Installation

• Operation methods

• Window reference

• List of error messages

• Index

How to Use This Manual It is assumed that the reader of this manual has general knowledge of microcontrollers,

C language, assembly language, and debugging as well as basic knowledge of

WindowsTM operations.

To understand the hardware functions and instruction functions of the VR4100 Series,

VR4300 Series, and VR5432:

→ Refer to the User’s Manual for the relevant product.

Conventions [        ]: Indicates a menu.

  text  : Indicates a button in a window or dialog box.

<<   >>: Indicates a text string displayed in a window or dialog box.

Data significance: Higher digits on the left and lower digits on the right

Memory map address:  Higher address on the top and lower address on the bottom

Active low representation: ××× (overscore over pin or signal name)

Note: Footnote for item marked with Note in the text

Caution: Information requiring particular attention

Remark: Supplementary information

Numerical representation: Binary... XXXX or XXXXB

Decimal... XXXX

Hexadecimal... 0xXXXX

Prefix indicating the power of 2 (address space, memory capacity):

K (kilo): 210 = 1024

M (mega): 220 = 10242
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Related Documents When using this manual, the following documents may be referenced.

The related documents indicated in this publication may include preliminary versions.

However, preliminary versions are not marked as such.

Documents related to development tools for VR4100 Series, VR4300 Series, and VR5432 (user’s

manuals)

Document Name Document No.

Basics U14833E

Technical U14835E

RX4000 µITRON4.0 (Real-time OS)

Installation U14834E

RD4000 (Task debugger) To be prepared

AZ4000 Ver. 4.00 (System performance analyzer) This manual
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CHAPTER  1   OVERVIEW

As steady progress is made in developing microprocessors with ever higher levels of performance and

functionality, user programs are growing in both size and complexity.

Although logical debugging of these user programs can be readily performed using conventional debuggers,

timing-related analyses such as analysis of abnormalities due to the timing of processing or evaluation of overall

system performance can be difficult and time-consuming.

In response to these market conditions, NEC, as a provider of powerful microprocessors such as the VR4100

Series,  VR4300 Series, and VR5432 64-bit microcontrollers, has developed and marketed the system performance

analyzer (hereafter referred to as “the AZ4000”) to provide support for quantitative performance analysis of user

programs.

The AZ4000 is a performance analysis tool that is used to analyze the execution status transitions, CPU execution

efficiency, and other performance characteristics of user programs included with the RX4000 real-time OS (hereafter

referred to as “the RX4000”).

The AZ4000 can be linked with the debugger to trace information (service calls, interrupt events, etc.) that is

specific to the real-time OS, and it provides graphical functions to display the resulting data.

These functions can be used to easily analyze task execution state transitions and access to objects such as event

flags and semaphores.

The AZ4000 is compliant with the tool interface protocol (hereafter, “TIP”), which means that the AZ4000’s

functions can be easily used with any debugger that also complies with this interface.

1.1 Overview

The AZ4000 is a performance analysis tool that is used to analyze the execution state transitions, CPU execution

efficiency, and other performance characteristics of user programs included with a RTOS (Real-Time OS), and it

provides graphical functions to display the resulting data.

The AZ trace data that is collected by the AZ4000 includes detected events (service calls, interrupts, etc.) that

controlled the RTOS, and this data can be used to easily analyze task execution state transitions and access to

objects such as event flags and semaphores.

The AZ4000 uses a “soft trace form.”
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1.2 Functions and Features

The AZ4000’s functions and features are described below.

(1) Graphical display of task execution state transition

A graphical display of a task or interrupt’s execution state transition (graph’s horizontal axis indicates time and

vertical axis indicates task or interrupt name, etc.) facilitates analysis of system progress caused by task

switching or interrupt events. In addition, symbols are used to indicate the status of access via service calls to

various objects to facilitate checking of task execution state transition.

(2) Graphical display of CPU usage

The display of CPU usage status within a specified time period provides histograms that facilitate analysis of

the system’s overall execution efficiency.

(3) Processing time statistics

Frequency calculations of execution time for any processing related to the user programs can be performed,

enabling worst-case values and average values to be obtained.

(4) Operation linked with debugger window

User can jump from the AZ4000’s window to a window displaying the debugger’s source text, disassembled

text, or memory contents to identify problems easily.
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1.3 System Configuration

The AZ4000 expands upon the debugger’s functions by communicating with the debugger via TIP-compliant

messages. The AZ4000’s system configuration and supported debug environment are described below.

1.3.1 When using debug monitor

Figure 1-1.  System Configuration Diagram (When Using Debug Monitor)

Host machine

Target system

Messages

RX4000

Compiler

AZ4000

VR4xxx

TIP-compliant
debugger

Caution At least one unused timer counter is required on the target system (the VR4100/4300/5432 CP0

register’s counter register that is used by the RX4000 can be shared).
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1.3.2 When using ROM emulator

Figure 1-2.  System Configuration Diagram (When Using ROM Emulator)

Host machine

Target system

Messages

ROM emulator

VR4xxx

RX4000

Compiler

AZ4000

TIP-compliant
debugger

Caution At least one unused timer counter is required on the target system (the VR4100/4300/5432 CP0

register’s counter register that is used by the RX4000 can be shared).
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1.4 Operating Environment

When using the AZ4000, a operating environment for the debugger is required.

(1) Host machine

PC-9821 Series, PC98-NX Series, or IBM PC/AT™ compatible

 CPU:  Pentium™ (100 MHz or above)

 Main memory: 32 MB or above

 OS:  Windows 95, Windows 98, or Windows NT™ 4.0

 Screen size:  640 × 400 pixels or greater (800 × 600 pixels or greater is recommended)

(2) Software

 C compiler package

CCMIPE:  Manufactured by Green Hills Software™, Inc. (U.S.A.)

 Real-time OS

RX4000 (µITRON4.0)

 Debugger

TIP-compliant debugger

(3) ROM emulator

Any ROM emulator that can be connected to a TIP-compliant debugger.
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CHAPTER  2   CREATION  OF  AZ MONITOR

This chapter describes the method used to create the AZ monitor that is required when using the AZ4000, along

with relevant caution points.

2.1 Creation of AZ Monitor (Monitor Program)

When using the AZ4000 with a soft trace form, the AZ4000’s AZ monitor (monitor program) collects AZ trace data.

The AZ4000 collects the timing information required for this via the user’s target timer counter (the

VR4100/4300/5432 CP0 register’s counter register that is used by the RX4000 can be shared as the timer counter).

Consequently, the AZ monitor cannot be completed until a monitor program has been created in which the timer

counter’s control block is coded to suit the user’s target (this block is hereafter called the “user’s own coding block”).

A step-by-step description of the method for creating the AZ monitor is given below.

2.1.1 Creation of user’s own coding block

This is the coding of the control block for the target timer counter. When creating this coding block, refer to the

sample programs contained in the directories listed below.

 For VR4100

nectools32\smp4100_ghs \az4000\Big\azusr.mip

nectools32\smp4100_ghs \az4000\Little\azusr.mip

 For VR4300

nectools32\smp4300_ghs \az4000\Big\azusr.mip

nectools32\smp4300_ghs \az4000\Little\azusr.mip

 For VR5432

nectools32\smp5000_ghs \az4000\Big\azusr.mip

nectools32\smp5000_ghs \az4000\Little\azusr.mip
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[Specification of data and functions in user’s own coding block]

An example of the data and functions specified in the user’s own coding block is given in Figure 2-1 (for the

target timer counter).

Figure 2-1.  Example of Timer Counter Operations (Up Counter)

Clear and start

Start timer count Interval period

tpc

Count value = n

Count value = 0

_AZMON_MaxCount (data)

This specifies the timer’s maximum count value (n value in Figure 2-1).

Data type:  Specify as 4-byte integer type (.word)

→ When RX4000 and timer are sharing counter register:  0x000

_AZMON_CountMode (data)

This specifies the count mode.

Data type:  Specify as single-byte integer type (.byte)

Data setting:  0x00 ... Up counter, 0x01 ... Down counter

→ When RX4000 and timer are sharing counter register:  0x00

 _AZMON_TimePerCount (data)

This specifies the time per count in microseconds (µs). (See tpc value in Figure 2-1.)

Data type:  Specify as 4-byte floating decimal type (.float)

→ When RX4000 and timer are sharing counter register:  0.0

 _AZMON_InitTimer (function)

This specifies the timer’s initialization processing.

Input register:  $ra ... return address

Output register:  None

Volatile register:  According to C-language call conventions

→ When RX4000 and timer are sharing counter register:  Processing is not specified
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 _AZMON_GetCounter (function)

This specifies the timer’s counter value read processing.

Input register:  $ra ... return address

Output register:  $v0 ... Counter value

Volatile register:  $at, $t4

→ When RX4000 and timer are sharing counter register:  Specifies counter register read processing

Cautions 1. When sharing the VR4100/4300/5432’s CP0 register that is used by the RX4000, do not

mask the RX4000’s “basic clock interrupt.”

2. The accuracy of times indicated as AZ trace data depends on the _AZMON_TimePerCount

value (tpc value in Figure 2-1).

3. Correct time information will not be displayed if the event interval in the collected AZ

trace data is longer than the timer counter’s interval.
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[Example of user’s own coding block (azusr.mip)]

.globl __AZMON_MaxCount

.globl __AZMON_CountMode

.globl __AZMON_TimePerCount

.globl __AZMON_InitTimer

.globl __AZMON_GetCounter

.section”.azmon_t”,.text

.align  4

__AZMON_MaxCount:

.word   0x0     /* MaxCountValue */   …Timer’s maximum count value

.section”.azmon_t”,.text

.align  4

__AZMON_CountMode:

.byte   0       /* CountMode */       …Timer’s count mode

.section”.azmon_t”,.text

.align  4

__AZMON_TimePerCount:

.float  0.0     /* TimePerCount */    …Time per count (unit: µs)

.section”.azmon_t”,.text

.align  4

__AZMON_InitTimer:

jr   $ra     /* The-Code-of-InitTimer */   …Timer’s initialization processing code

.section”.azmon_t”,.text

.align  4

__AZMON_GetCounter:

mfc0 $v0, $9 /* The-Code-of-GetCounter */  …Timer’s count value read processing code
nop

nop

jr   $ra



CHAPTER  2   CREATION  OF  AZ MONITOR

User’s Manual  U15031EJ1V0UM20

2.1.2 Creation of AZ monitor

After creating the user’s own coding block, perform the following steps to complete the AZ monitor (azmon.o).

 Use CCMIPE (manufactured by Green Hills Software, Inc.)

Start the batch file mkmon.batNote 1, then create the monitor program azmon.oNote 2. It may be necessary to revise

the tool path specified in mkmon.bat to suit the development environment being used.

mkmon.bat specifies the following processing.

1. Assemble azusr.mipNote 3

2. Link to azcore.o and create azmon.o

Notes 1. mkmon.bat (batch file)

 For VR4100

nectools32\smp4100_ghs \az4000\Big\ mkmon.bat

nectools32\smp4100_ghs \az4000\Little\ mkmon.bat

 For VR4300

nectools32\smp4300_ghs \az4000\Big\ mkmon.bat

nectools32\smp4300_ghs \az4000\Little\ mkmon.bat

 For VR5432

nectools32\smp5000_ghs \az4000\Big\ mkmon.bat

nectools32\smp5000_ghs \az4000\Little\ mkmon.bat

2. azmon.o (monitor program)

 For VR4100

nectools32\smp4100_ghs \az4000\Big\ azmon.o

nectools32\smp4100_ghs \az4000\Little\ azmon.o

 For VR4300

nectools32\smp4300_ghs \az4000\Big\ azmon.o

nectools32\smp4300_ghs \az4000\Little\ azmon.o

 For VR5432

nectools32\smp5000_ghs \az4000\Big\ azmon.o

nectools32\smp5000_ghs \az4000\Little\ azmon.o

3. azusr.mip (sample program with user’s own coding block)

 For VR4100

nectools32\smp4100_ghs \az4000\Big\ azusr.mip

nectools32\smp4100_ghs \az4000\Little\ azusr.mip

 For VR4300

nectools32\smp4300_ghs \az4000\Big\ azusr.mip

nectools32\smp4300_ghs \az4000\Little\ azusr.mip

 For VR5432

nectools32\smp5000_ghs \az4000\Big\ azusr.mip

nectools32\smp5000_ghs \az4000\Little\ azusr.mip
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2.2 Cautions

The following are cautions concerning the use of the soft trace form.

2.2.1 Points to be noted when creating load modules

The link files used when building the load module in two parts are described below.

♦ User program’s load module

SIT file, user processing program (task, handler), initialization processing file (initialization handler), idle handler,

run-time library file, link directive file

♦ Kernel load module

SCT file, initialization processing file (hardware initialization block), AZ monitor, RX4000 µITRON4.0 library file,

entry processing file, link directive file

Caution When creating a kernel load module, the AZ monitor must be specified before the nucleus library

(librx.a) in the link directive file.

[Specification of sections in AZ monitor]

When creating the load module (or the nucleus load module when the load module is divided in two), be sure to

specify the AZ monitor sections shown below in the link directive file.

• .azmon_b:  AZ monitor’s work area

• .azmon_t:  AZ monitor’s text/data area

Caution The .azmon_b section must be allocated to a read/write-accessible area of RAM. Do not

perform any write operations (initialization processing, etc.), such as via the user program in

this RAM area.

[Example of AZ monitor section specifications]

.system_entry 0x80000180 :

.system 0x80004000 :

.sct :

.azmon_t 0x8000c000 : ←This specification is added.

.azmon_b 0x8000d000 : ←This specification is added.

.boot 0xbfc00000 :

.text 0x80010000 :

.sit :

.data :

.sdata :

.sbss :

.bss :

.stack 0x8002c000 :
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2.2.2 Points to be noted when debugging

(1) Resources used by AZ4000

• AZ monitor’s text/data area:  approximately 1600 bytes

• AZ monitor’s work area (.bss attribute): 64 bytes

• Trace buffer region:  4 KB to 4 MB (recommended:  64 KB to 1 MB)

• Timer counter:  1 (timing information displayed as AZ trace data is captured from

the target’s timer counter)

Caution Since timing information is captured from the target’s timer counter when collecting trace

data, a AZ4000-compatible timer counter is required (the VR4100/4300/5432 CP0 register’s

counter register that is used by the RX4000 can be shared).

(2) Trace memory

• To clear the contents of trace memory, select “AZ trace ON”Note.

Note This mode sets the AZ4000’s trace function as valid. To set this function, go to the AZ4000 window’s

menu bar and enter a check next to [AZ Trace ON] in the [Operation] menu. This enables collection of

AZ trace data.

(3) Time measurements

• When sharing the timer counter (the VR4100/4300/5432 CP0 register’s counter register) that is used by the

RX4000 with the timer counter for capturing the AZ4000’s timing information, do not mask the RX4000’s

“basic clock interrupt.”

• The accuracy of times indicated as AZ trace data depends on the timer counter’s “count up” time.

For example, if the timer counter has a count up time (tpc) of 1 µs, the unit for times displayed by the

AZ4000 is 1 µs.

• Correct time information will not be displayed if the event interval in the collected AZ trace data is longer than

the timer counter’s interval.

2.2.3 Points to be noted for AZ trace data

(1) Items that cannot be detected

The items described below cannot be detected as AZ trace data.

• Start and end of cycle start handler

• Start and end of interrupt service routine that does not operate via the RX4000 (start and end of interrupt

service routine registered via cre_isr or acre_isr are detected)

• Start and end of service call exception handler (occurrence and recovery of CPU exception handler

registered via def_exc are detected)

• Service call (ext_tsk, exd_tsk) address

Consequently, the jump function cannot be used from this location on the state transition diagram.
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CHAPTER  3   INSTALLATION

This chapter describes the AZ4000’s installation method and activation/termination methods.

3.1 Installation of AZ4000

Perform the following steps to install the AZ4000.

<1> The software is provided on CD-ROM media. Insert the CD-ROM disc into the host machine’s CD-ROM

drive.

<2> Using a program such as Windows Explorer, start the executable file “setup.exe” in the CD-ROM’s “DISK1”

directory. Next, follow the instructions given in the displayed message to install the AZ4000.

3.2 Activation and Termination

3.2.1 Activation method

Use either of the following methods to activate the AZ4000.

• Double-click “az4000.exe” in the “nectools32\bin” directory.

• Select the AZ4000 icon from the Windows Start menu.

3.2.2 Termination method

Use either of the following methods to close the AZ4000.

• Select [File] → [Exit] on the AZ4000 window’s menu bar.

• Click the Close button at the upper right part of the AZ4000 window.
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CHAPTER  4   OPERATION  METHODS

The basic debugging method used with the AZ4000 is described step by step below.

(1) Start debugger

Start the debugger.

(2) Start AZ4000

Start the AZ4000 and open the AZ4000 window.

Make sure that “Connected” is displayed in the <<status view area>>. “Connected” is displayed to indicate a

successful connection to the debugger.

(3) Download load module

Download the load module that was created to support the AZ4000.

Make sure that “RX+AZ Loaded” is displayed on the status bar in the AZ4000 window.

(4) Settings in AZ Option dialog box

Open the AZ Option dialog box and set following options.

•••• Settings in trace buffer region

In the AZ Option dialog box, specify the start and end addresses of the <<Trace Buffer>> region where trace

data will be stored.

•••• Select trace level

For <<Trace Level>>, select the trace level of the AZ trace data to be collected.

In this version, only “Task Level” can be selected for the trace level. Download to the debugger the load

module that was created for the AZ4000.

(5) AZ trace mode switching

Set <<AZ Trace ON>> to activate the AZ4000’s trace function.

Caution The load module must be downloaded (to load the required symbol information) before the

AZ Trace ON setting can be made.

(6) Execute user program

Execute the user program on the debugger.

As the user program is being executed, trace data for the AZ4000 starts accumulating in the trace buffer.

(7) Stop the user program

Stop the user program that is being executed on the debugger (if a breakpoint has been set, wait until the

break occurs).

Collection of trace data for the AZ4000 stops when execution of the user program is stopped.

(8) Upload trace data

When uploading, the trace data that has accumulated in the trace buffer is converted to AZ trace data.
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(9) Check in Analyze window

Open the Analyze window and check the accumulated AZ trace data in each task’s state transition chart.

•••• How to display the state transition chart

On the AZ4000 window’s menu bar, select [Browse] → [Analyze] → [Task Level], or click the  button on

the tool bar.

•••• How to check the operation of objects

Click on any object name to display the “simple search button,” then check the specified object’s operation.

•••• How to check task or interrupt state transitions

Use the Pattern Search dialog box that is opened from this window to search for a particular task switching

point, interrupt source location, or service call location.

→ The search results are displayed in the state transition chart.

•••• How to analyze the task or interrupt processing time

Use the Pattern Set dialog box that is opened from this window to search or analyze the previously set

pattern (specified processing).

→ The search results are displayed in the state transition chart.

→ The distribution status based on the set pattern’s processing time is displayed in the Pattern window.

(10) Check in CPU window

Use the CPU window to verify CPU usage during defined periods.

•••• How to display the CPU usage rate

Set the up and down cursors at start and end of the target period for displaying the CPU usage rate in the

state transition chart.

The displayed CPU usage rate is that for the period between the up and down cursors. After setting these

cursors, open the CPU window.

Remark When the CPU window is active, the CPU usage rate is automatically updated when the up cursor or

down cursor is moved to another location on the task-level state transition chart.
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(11) Check in Pattern window

Use the Pattern window to verify the distribution status of a specified pattern’s execution time.

•••• How to display the pattern distribution

[Display method for any pattern]

<1> In the Analyze window, use the up and down cursors to define the period for the pattern distribution to

be displayed.

<2> In the Analyze window, select [Browse] → [Pattern] on the menu bar.

<3> In the Pattern Set dialog box (which opens automatically), set the conditions for the pattern to be

displayed, then click the  OK  button in the dialog box.

[Display method starting from CPU window]

<1> In the Analyze window, use the up and down cursors to define the period for the pattern distribution to

be displayed.

<2> In the CPU window, select any object in the list, then select [Jump] → [Pattern] on the menu bar.

The pattern distribution displayed via these methods are based on data for the specified object’s processing

period (i.e., the mode between the start and end points for switching the specified objects).

Remark When the Pattern window is active, the pattern distribution is automatically updated when the up

cursor or down cursor is moved to another location on the task-level state transition chart.

(12) Check in Trace View window

More detailed verification of collected AZ trace data can be performed via the Trace View window.

•••• How to display AZ trace data

Move the temporary up cursor to the target position in the state transition chart. If the temporary up cursor is

not being displayed, it is at the trace data display’s start position.

After setting the cursor, open the Trace View window.

Remark When the Trace View window is active, the AZ trace data display’s start position is automatically

updated when the up cursor or down cursor is moved to another location on the task-level state

transition chart.

When necessary, repeat starting from step (6) to continue debugging.

Remark When using the soft trace form, resetting AZ trace ON clears the trace buffer contents.
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CHAPTER  5   WINDOW  REFERENCE

This chapter provides a detailed description of the AZ4000’s window and dialog box functions.

5.1 Overview of AZ4000 Windows and Dialog Boxes

Table 5-1 lists the AZ4000 windows and dialog boxes.

Table 5-1.  List of AZ4000 Windows and Dialog Boxes

Window/Dialog Box Description of Function Page

AZ4000 window Used to perform AZ4000’s basic operations p.30

AZ Option dialog box Used to set trace form, CPU type, and trace level p.35

Analyze window Used to display state transition chart of collected AZ trace data p.37

Object Select dialog box Used to select objects to display on the state transition chart or to specify changes

of order

p.49

Pattern Search dialog box Used to set search conditions and perform searches in state transition charts p.52

CPU window Used to display CPU usage during a specified time range in state transition charts p.56

Pattern Set dialog box Used to set patterns to be displayed in Pattern window p.61

Pattern window Used to display a histogram of distribution results, based on the execution time

length, for the specified pattern in the state transition chart

p.65

Trace View window Used to display a list of collected AZ trace data p.72

Trace Search dialog box Used to set search conditions and perform searches in the Trace View window p.77

File Select dialog box Used to load or save contents of various AZ4000 windows to a “view file” p.80
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5.2 Relations among AZ4000 Windows and Dialog Boxes

Figure 5-1 illustrates the relations among AZ4000 windows and dialog boxes.

Figure 5-1.  Relations among AZ4000 Windows and Dialog Boxes

AZ4000 window

AZ Option dialog box

Analyze window

Object Select dialog box

Pattern Search dialog box

AZ Option

Analyze Window

Object Select

Pattern Search

CPU window

CPU Window

Pattern Set dialog box

Pattern Set

Pattern window

Pattern Window

Trace View window

Trace View Window

Trace Search dialog box

Trace Search

File Select dialog box

File Open
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5.3 Descriptions of Windows and Dialog Boxes

Windows and dialog boxes are described below using the following format.

Window/dialog box name
 [Window/dialog box name]

[General]

Description of window or dialog box’s functions and how it is opened

[Window]

Illustration of window or dialog box’s on-screen elements

[Functions]

Detailed description of window or dialog box’s functions

[Function buttons]

Description of operations set via window or dialog box’s buttons; describes how to select of target operation

before clicking a button

[Menu bar]

Description of how functions can be specified by selecting items from pull-down menus under titles in the

menu bar

[Caution]

Description of cautions concerning window or dialog box’s operations

[Errors]

Description of errors or warnings that can occur when window or dialog box’s operations are being performed
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AZ4000 Window
[AZ4000]

[General]

This window opens automatically after the AZ4000 is started. It contains the AZ4000’s basic operations. Start

from this window when using the AZ4000.

[Window]

Figure 5-2.  AZ4000 Window

(a) Tool bar

(b) Status bar

[Functions]

(1) Description of areas

(a) Tool bar

These buttons are clicked once to select and execute frequently used menu items.

•••• AZ Option dialog box button 

Click this button to open the AZ Option dialog box.

Use this dialog box to specify various options for AZ trace operations.

•••• [AZ Trace ON/OFF] button 

This is a toggle button that turns the AZ4000’s trace function on and off.

When “AZ Trace ON” has been set, AZ trace data can be collected.

Cautions 1. The “AZ Trace ON” setting cannot be made until downloading of the AZ4000’s

soft trace form load module has been completed.

2. When using the soft trace form, after switching from “AZ Trace ON” to “AZ Trace

OFF”, setting “AZ Trace ON” again clears the contents of trace memory.
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•••• [Upload] button 

When this button is clicked, trace data obtained by executing a user program is read from trace

memory and converted to AZ trace data.

Cautions 1. If the Analyze window is open, clicking on this button updates the state transition

chart to display the latest AZ trace data.

2. If there is no trace data in the trace memory, this button cannot be selected.

•••• Display Analyze window button 

Click this button to open the task-level Analyze window.

This window can be used to check state transitions for individual tasks.

(b) Status bar

The status bar is an area used to display various AZ4000 status indicators.

•••• Connection status view area (first area from left)

This area shows the status of the debugger connection.

Connected:  Connection with debugger is successful

Not Connected:  No connection with debugger

•••• Load module status view area (second area from left)

This area shows the status of the load module that has been loaded into the debugger.

This area is not displayed unless the AZ4000 is connected with a debugger.

RX+AZ None:  Both or either of the RTOS and AZ monitors has not been downloaded.

RX+AZ Loaded:  Both the RTOS and AZ monitors have been downloaded.

•••• Load module execution status view area (third area from left)

This area displays the execution status of a user program.

This area is not displayed unless the AZ4000 is connected with a debugger.

Running:  User program is being executed

Breaked:  Execution of user program has been stopped (at a breakpoint)

•••• Trace mode status view area (fourth area from left)

This area displays the AZ trace ON/OFF status.

This area is not displayed unless the AZ4000 is connected to a debugger and a load module has been

downloaded (i.e., the required symbol data has been downloaded).

AZ Trace ON:  Indicates that AZ trace is set to ON

AZ Trace OFF:  Indicates that AZ trace is set to OFF
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[Menu bar]

(1) [File] menu

File Option Operation Browse Window Help_ _ _ _ _

Exit_

_

Exit:  This closes the AZ4000.

(2) [Option] menu

File Option Operation Browse Window Help_ _ _ _ _ _

Tool Bar_

Status Bar_

Az Option..._

Tool Bar:  This selects whether or not to display a tool bar in this window. When selected, a

tool bar is displayed.

Status Bar:  This selects whether or not to display a status view area in this window. When

selected, a status view area is displayed.

Az Option...:  This opens the AZ Option dialog box. Use this dialog box to specify various

options before performing an AZ trace. This has the same operation as the 

button on the tool bar.
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(3) [Operation] menu

File Option Operation Browse Window Help_ _ _ _ _ _

AZ Trace ON_

_

Upload_

AZ Trace OFF

AZ Trace ON:  This sets the AZ trace mode to “AZ Trace ON”. When this has been selected, “AZ

Trace ON” is set and trace data is collected in trace memory as the user program

is executed.

AZ Trace OFF:  This sets the AZ trace mode to “AZ Trace OFF”. When this has been selected, “AZ

Trace OFF” is set and trace data is not collected in trace memory when the user

program is executed.

Upload:  This uploads trace data. The trace data that was collected during execution of a

user program is read from the trace buffer and is converted to AZ trace data. Also,

if the Analyze window is open, selecting this menu item updates the state

transition chart to display the latest AZ trace data.

This has the same operation as the  button on the tool bar.

Cautions 1. [AZ Trace ON] cannot be selected unless the AZ4000 has downloaded both the RTOS

and AZ monitor (soft trace form), as indicated by [RX+AZ Loaded] in the status bar.

2. [AZ Trace ON] cannot be selected while a user program is being executed.

3. [Upload] cannot be selected unless some trace data exists in the trace buffer.

(4) [Browse] menu

File Option Operation Browse Window Help_ _ _ _ _ _

Analyze..._
Task Level..._

Analyze…:  This displays a sub menu that is used to open the Analyze window. The following

item is shown in the sub menu.

Task Level…:  This opens the task-level Analyze window. This has the same operation as the

 button on the tool bar.
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(5) [Window] menu

File Option Operation Browse Window Help_ _ _ _ _ _

Close All_

Close All:  This closes all of the AZ4000’s open windows and dialog boxes.

(6) [Help] menu

File Option Operation Browse Window Help_ _ _ _ _ _

This Window_

Help Topics_

About..._

This Window:  This displays help topics about this window.

Help Topics:  This opens a dialog box for searching the AZ4000’s help contents (topics).

About...:  This opens a message box containing the AZ4000’s version information.

[Cautions]

• For “AZ Trace ON” to be set, the AZ4000 must download both the RTOS and AZ monitor (soft trace form), as

indicated by [RX+AZ Loaded] in the status bar.

•  “AZ Trace ON” cannot be set while a user program is being executed.

• When using the soft trace form, setting “AZ Trace ON” clears the contents of trace buffer.

• The AZ4000 window does not change when trace data is uploaded. To view the trace data, open the Analyze

window after the trace data has been uploaded.

[Errors]

• When uploading, an Error dialog box will be displayed if there is no trace data in the trace buffer.

• An Error dialog box will be displayed if an error occurs when switching the AZ trace mode.

• An Error dialog box will be displayed if an error occurs during “upload” processing of trace data.
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AZ Option Dialog Box
[AZ Option]

[General]

This dialog box is used to specify the AZ4000’s trace form, the target real-time OS, the trace buffer type, trace

buffer region, and the trace level of the AZ trace data to be collected.

This dialog box can be opened via any of the following operations.

• In the AZ4000 window, select [Option] → [Az Option] on the menu bar.

• In the AZ4000 window, click the  button.

• Press and hold the  Alt  key while pressing the  P  and  Z  keys in that order.

[Window]

Figure 5-3.  AZ Option Dialog Box

(a)  Specify trace form

(b) Trace buffer type 
specification area

(c) Trace buffer region 
specification area

(a)  Trace form specification area

[Functions]

The areas in this dialog box are described below.

(a) Trace form specification area

Use this area to specify the AZ4000’s trace form. In this case, the soft form is specified.
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(b) Trace buffer type specification area

When “soft form” has been specified as the trace form, this area is used to specify the trace buffer type.

Select the option button for the environment to be used.

•••• Fixed Buffer

This selects fixed buffer as the trace buffer type.

When the trace buffer becomes full, collection of trace data ends. Consequently, there is no guaranty

that all trace data until the program is stopped will be collected.

•••• Ring Buffer

This selects ring buffer as the trace buffer type.

Once the trace buffer becomes full, the trace data is overwritten starting from the oldest data.

(c) Trace buffer region specification area

This area is used to specify the trace buffer region to be used with the soft trace form.

Enter the start address and end address in the text box.

With the soft trace form, the trace data collected by the AZ4000 is first stored in the target memory.

Therefore, an unused area in the target memory must be specified as the trace buffer region.

Specify an area whose size ranges from 4 KB to 4 MB.

[Function buttons]

Target Operation Button Function

Condition Run AZ4000 using the specified trace form, trace buffer region, and trace level.

− Closes this dialog box.

− Displays help topics about this dialog box.

[Errors]

• If the address range specified in the trace buffer region specification area is incorrect, the Error dialog box will

be displayed once the  OK  button has been clicked.
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Analyze Window
[Analyze Window]

[General]

This window displays a task-level state transition chart of the AZ trace data collected during execution of a user

program.

This window and the windows that are displayed via this window can be used to search or analyze system timing

errors and the entire system at the task level.

This window can be opened via any of the following operations.

• In the AZ4000 window, select [Browse] → [Analyze] → [Task Level] on the menu bar.

• In the AZ4000 window, click the  button.

• Press and hold the  Alt  key while pressing the  B ,  Z , and  T  keys in that order.

[Window]

Figure 5-4.  Analyze Window

(a)

(b)

(c)

(d)(e) (f)

(g) (h) (i) (j) (k)

(l) (m)

(n)
(o) (p)

(a) Up cursor (i) Time display between cursors

(b) Down cursor (j) Time display at temporary up cursor position

(c) Temporary up cursor (k) Data width

(d) Temporary down cursor (l) “Jump to start” button

(e) Object (m) “Jump to end” button

(f) Analysis results (state transition) (n) Scale change button

(g) Time display at up cursor position (o) Simple search button

(h) Time display at down cursor position (p) Time area
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[Functions]

The following items are described below.

(1) Description of areas

(2) Display method for state transition chart

(3) Object names

(4) How to read state transition charts

(5) Search methods for state transition charts

(1) Description of areas

(a) Up cursor

This cursor is used to specify the range used when checking processing times in AZ trace data or when

tabulating various types of data (it specifies the start position for the tabulation range).

[Operation method]

Press and hold the  Shift  key while clicking the mouse on the state transition chart.

(b) Down cursor

This cursor is used to specify the range used when checking processing times in AZ trace data or when

tabulating various types of data (it specifies the end position for the tabulation range).

[Operation method]

Press and hold the  Ctrl  key while clicking the mouse on the state transition chart.

(c) Temporary up cursor

Use this cursor to specify a position for starting a search via the “simple search button”, a position for

displaying results of a pattern search, or a start point when jump to the debugger window.

When displaying search results from the Pattern window, use this cursor to indicate the search pattern’s

start position.

When the up cursor is moved, the temporary up cursor is automatically moved to the same position.

[Operation method]

Click the left mouse button.

(d) Temporary down cursor

When displaying search results from the Pattern window, use this cursor to indicate the search pattern’s

end position.

When the down cursor is moved, the temporary down cursor is automatically moved to the same

position.

(e) Object

These buttons indicate objects in the AZ trace data.

The button labels display RX4000-related objects (resources), such as tasks, event flags, and

mailboxes. For further description of object names, see (3) Object names below.

Clicking on an object name causes a simple search button to be displayed. Click the object name again

to remove the simple search button.
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(f) Analysis results (state transition)

This area displays the user program analysis results. For further description of marks shown in the state

transition chart, see (4) How to read state transition charts below.

(g) Time display at up cursor position

Relative time from the start of AZ trace data collection to the up cursor position is displayed here. The

unit of measurement is milliseconds (msec).

(h) Time display at down cursor position

Relative time from the start of AZ trace data collection to the down cursor position is displayed here. The

unit of measurement is milliseconds (msec).

(i) Time display between cursors

The length of time between the up cursor and down cursor is displayed here. The unit of measurement

is milliseconds (msec).

(j) Time display at temporary up cursor position

Relative time from the start of AZ trace data collection to the temporary up cursor position is displayed

here. The unit of measurement is milliseconds (msec).

(k) Data width

This displays the time span between the start and end of the AZ trace data.

(l) “Jump to start” button

This moves the up cursor and display screen to the start of the AZ trace data.

(m) “Jump to end” button

This moves the down cursor and display screen to the end of the AZ trace data.

(n) Scale change button

This changes the scale of the displayed state transition chart. Select the desired display scale from the

pull-down menu or using the spin button.

(o) Simple search button

This searches for the specified object. Click on a listed object name, then click on the  button that

appears to search an object along the time axis (forward) of the state transition chart. The temporary up

cursor is moved to the search position.

Clicking the  button searches the specified object along the time axis’s backward direction, and

moves the temporary up cursor to the search position.

(p) Time area

This area displays the time unit for the event intervals displayed in the state transition chart. The unit is

displayed at the right edge of this area. In Figure 5-4, the unit is milliseconds (msec).
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(2) Display method for state transition chart

Perform the operations described below to display a state transition chart of collected AZ trace data in this

window.

[Operation method]

<1> Collect AZ trace data.

<2> Open this window (select [Browse] → [Analyze] → [Task Level] on the AZ4000 window’s menu bar, or

click the  button on the tool bar).

Data in this window is not automatically updated. Consequently, when re-executing a user program, in order

to have the newly collected trace data displayed in a state transition chart, select the upload function (select

[Operation] → [Upload] on the AZ4000 window’s menu bar or click the  button).

(3) Object names

Buttons that indicate object names are displayed as shown below.

•••• RX4000 objects

Idle tasks are displayed as follows.

Idle task

Resource types and ID numbers are displayed as follows.

Task (nnnn:  task ID No. {hexadecimal})

Event flag (nnnn:  event flag ID No. {hexadecimal})

Semaphore (nnnn:  semaphore ID No. {hexadecimal})

Mailbox (nnnn:  mailbox ID No. {hexadecimal})

Variable length memory pool (nnnn:  memory pool ID No. {hexadecimal})

Fixed length memory pool (nnnn:  memory pool ID No. {hexadecimal})

Data queue (nnnn: data queue ID No. {hexadecimal})

Mutex (nnnn: mutex ID No. {hexadecimal})

•••• Interrupts

The interrupt handler name received from the debugger is displayed. However, in cases where the handler

name cannot be received from the debugger, the following default names are displayed.

Maskable interrupt (N: interrupt level {0 to 7})

Non-maskable interrupt
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•••• Exceptions

The exception name is displayed.

TLB modification exception

TLB mismatch exception (load or fetch)

TLB mismatch exception (store)

Address error exception (load or instruction fetch)

Address error exception (store)

Bus error exception (instruction fetch)

Bus error exception (data load or store)

Breakpoint exception

Reserved instruction exception

CPU disable exception

Operation overflow exception

Trap exception

Floating point operation exception

Watch exception

•••• Other objects

Objects that are not displayed in the Object Select dialog box.

(4) How to read state transition charts

State transition charts have the following three view modes, which can be specified by selecting [View] →
[View mode] on the Analyze window’s menu bar.

(a) Delete mode

(b) Standard mode

(c) Detail mode (default)

Remark To view or hide grid lines, select [View] → [Grid mode] on this window’s menu bar.
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(a) Delete mode

Only horizontal lines are used to indicate where CPU operations occur. “Delete mode” is useful when

analyzing a wide range of AZ trace data.

Figure 5-5.  Analyze Window (Delete Mode)

Remark  Dotted lines indicate processing by the user program and bold lines indicate service call processing. 

(b) Standard mode

Lines are used to link CPU processing segments.

Figure 5-6.  Analyze Window (Standard Mode)

Remark  Dotted lines indicate processing by the user program and bold lines indicate service call processing. 

(c) Detail mode (default)

In addition to the traces of CPU processing, this mode displays marks that indicate whether service calls

of the RX4000 are for memory pool management or the communication control function (see Table 5-2).

Detail mode is useful when analyzing access to specific objects.
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Figure 5-7.  Analyze Window (Detail Mode)

Remark  Dotted lines indicate processing by the user program and bold lines indicate service call processing. 

(a) Tsk(1001) has issued a wai_flg service call in response to event flag flg(2000).

(b) Tsk(1001) is in wait mode, so processing is passed to Tsk(1002).

(c) Tsk(1002) has issued a set_flg service call in response to event flag flg(2000).

(d) The wait condition for the wai_flg service call issued by Tsk(1001) has been met and wait mode has been

canceled.

(e) Tsk(1001) has issued a del_mbx service call for mailbox mbx(4000).

(f) Tsk(1001) has issued a get_mpl service call in response to memory pool mpl(5000).

(g) An error has been returned by the service call described in (f) above.

(h) Tsk(1002) has issued a sig_sem service call in response to semaphore Sem(3000).

Table 5-2.  List of Marks Used in State Transition Charts (When Used in RX4000)

Mark Access Target Issued Service Calls Meaning

Event flag wai_flg / pol_flg / ipol_flg / twai_flg

Semaphore wai_sem / pol_sem / ipol_sem / twai_sem

Mailbox rcv_mbx / prcv_mbx / iprcv_mbx / trcv_mbx

Variable length memory pool get_mpl / pget_mpl / ipget_mpl / tget_mpl

Fixed length memory pool get_mpf / pget_mpf / ipget_mpf / tget_mpf

Data queue rcv_dtq / prcv_dtq / iprcv_dtq / trcv_dtq / snd_dtq / tsnd_dtq

Mutex loc_mtx / ploc_mtx / tloc_mtx

Event flag set_flg / iset_flg / clr_flg / iclr_flg

Semaphore sig_sem / isig_sem

Mailbox snd_mbx / isnd_mbx

Variable length memory pool rel_mpl / irel_mpl

Fixed length memory pool rel_mpf / irel_mpf

Data queue snd_dtq / psnd_dtq / ipsnd_dtq / tsnd_dtq / fsnd_dtq / ifsnd_dtq

Mutex unl_mtx

Event flag del_flg

Semaphore del_sem

Mailbox del_mbx

Variable length memory pool del_mpl

Fixed length memory pool del_mpf

Data queue del_dtq

Mutex del_mtx

Indicates that one
of the service calls
shown at left was
issued for the
corresponding
access target and
a value was
returned.

Indicates an error of an issued service call.



CHAPTER  5   WINDOW  REFERENCE

User’s Manual  U15031EJ1V0UM44

(5) Search methods for state transition charts

The following methods can be used to search collected AZ trace data in this window.

(a) Search processing of specific objects

(b) Search via Pattern Search dialog box

(c) Search via Pattern window

(a) Search processing of specific objects

Use the “simple search button” to search for processing of a specified object.

[Operation method]

<1> If a temporary up cursor is displayed in the state transition chart, move the temporary up cursor to

the search start position. If it is not displayed, move the up cursor to the search start position.

<2> Click the button bearing the name of the object whose operation is to be checked. The simple

search buttons will appear immediately to the right of the object name and also in the state

transition chart.

<3> Click a simple search button.

:  Searches for the specified object’s processing along the forward direction of the time axis

and moves the temporary up cursor to the search position.

:  Searches for the specified object’s processing along the backward direction of the time axis

and moves the temporary up cursor to the search position.

If the searched point is not in the currently displayed state transition chart, the graph is shifted so that

the point is at the “0” position in the scale.

The simple search button can be removed from the screen by clicking the button bearing the object

name again.

(b) Search via Pattern Search dialog box

Use the Pattern Search dialog box to search previously set patterns in state transition charts. The

search results are indicated by the temporary up cursor in the state transition chart.

When using the Pattern Search dialog box, the transition status of tasks and interrupts can be searched.

For details, see the description of the Pattern Search dialog box.

(c) Search via Pattern window

A pattern that has been set via the Pattern Set dialog box can be searched in the state transition chart

displayed in the Pattern window. The search results are indicated by the temporary up cursor in the state

transition chart.

When using the Pattern window, the transition status of tasks and interrupts can be searched. For

details, see the description of the Pattern window.
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[Function buttons]

Target Operation Button Function

− This opens the File Select dialog box. Previously saved trace data from the Analyze

window is read and displayed in the state transition chart.

− This opens the File Select dialog box. Currently displayed trace data (displayed in the

Analyze window) is saved to a file.

− This turns grid mode on and off for the state transition chart.

− This sets delete mode for the state transition chart.

− This sets standard mode for the state transition chart.

− This sets detail mode for the state transition chart.

− This opens the Object Select dialog box.

− This opens the Pattern Search dialog box.

− This opens the CPU window to display the CPU usage rate for the period between

the up and down cursors. If a previously active CPU window is being displayed, the

contents of that window are updated at this point.

− This opens the Pattern Set dialog box. Once a pattern condition has been set, a

Pattern window displaying the period between the up and down cursors is opened. If

a previously active Pattern window is being displayed, the contents of that window

are updated at this point.

− This opens the Trace View window from the position specified by the temporary up

cursor. If a previously active Trace View window is being displayed, the contents of

that window are updated at this point.

− This opens the Source Text window from the position specified by the temporary up

cursor. If a previously active Source Text window is being displayed, the contents of

that window are updated at this point.

− This opens the Disassemble window from the position specified by the temporary up

cursor. If a previously active Disassemble window is being displayed, the contents of

that window are updated at this point.

− This opens the debugger’s memory list from the position specified by the temporary

up cursor. If a memory list is being displayed in a previously active window, the

contents of that window are updated at this point.
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 [Menu bar]

(1) [File] menu

File View Operation Browse Jump Help_ _ _ _ _ _

Open..._

Save_

Save As..._

Print_

Close_

Open…:  This opens the File Select dialog box. A previously saved file displayed in this

window is loaded.

The default file name extension for files displayed in this window is “.az”.

Save:  This function is not supported in this version.

Save As…:  This opens the File Select dialog box. Currently displayed data in a state transition

chart is updated or renamed and saved to a view file in this window.

The default file name extension for files displayed in this window is “.az”.

Print:  This function is not supported in this version.

Close:  This closes this window.

Caution If a state transition chart is not being displayed, the [Save As...] menu item cannot be

selected.

(2) [View] menu

File View Operation Browse Jump Help_ _ _ _ _ _

Grid mode_

View mode_

Small_

Grid_

Delete Mode(O)_

Ungrid_

Standard mode_

Detail mode_

Large(T)

Search_

Select Object_

_

Grid mode:  This displays a sub menu that is used to specify view/hide for grid lines on the

state transition chart.

The following sub menu is displayed.

Grid:  This views (displays) grid lines.

Ungrid:  This hides grid lines.

View mode:  This displays a sub menu for specifying the state transition chart’s display mode.

The following sub menu is displayed.

Delete Mode(O):  This hides vertical lines in the state transition chart.

This has the same operation as clicking the  button.
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Standard mode:  This displays the CPU’s state transitions only.

This has the same operation as clicking the  button.

Detail mode:  This displays the service call access status for the RX4000 real-time OS (default

mode).

This has the same operation as clicking the  button.

Small:  This minimizes the display scale of the state transition chart. This has the same

operation as the scale change button (see Figure 5-4).

Large(T):  This maximizes the display scale of the state transition chart. This has the same

operation as the scale change button (see Figure 5-4).

Search:  This opens this window’s trace-level Pattern Search dialog box.

This has the same operation as clicking the  button.

Select Object:  This opens this window’s trace-level Object Select dialog box.

This has the same operation as clicking the  button.

(3) [Operation] menu

File View Operation Browse Jump Help_ _ _ _ _ _

Active_

Hold_

Active:  This switches this window from hold mode to active mode.

Hold:  This switches this window from active mode to hold mode.

(4) [Browse] menu

File View Operation Browse Jump Help_ _ _ _ _ _

CPU..._

Pattern..._

Trace View..._

CPU…:  This opens this window’s trace-level CPU window. If a previously active CPU

window is being displayed, the contents of that window are updated at this point.

This has the same operation as clicking the  button.

Pattern…:  This opens this window’s trace-level Pattern Set dialog box. Once a pattern is set

via this dialog box, the Pattern window is opened. If a previously active Pattern

window is being displayed, the contents of that window are updated at this point.

This has the same operation as clicking the  button.

Trace View…:  This opens this window’s trace-level Trace View window. If a previously active

Trace View window is being displayed, the contents of that window are updated at

this point.

This has the same operation as clicking the  button.
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(5) [Jump] menu

File View Operation Browse Jump Help_ _ _ _ _ _

Source Text..._

Assemble..._

Memory..._

Source Text…:  This displays the debugger’s source text at the position specified using the

temporary up cursor. If source text is already being displayed in an active window,

the contents of that window are updated at this point.

This has the same operation as clicking the  button.

Assemble…:  This displays the debugger’s disassembled text at the position specified using the

temporary up cursor. If disassembled text is already being displayed in an active

window, the contents of that window are updated at this point.

This has the same operation as clicking the  button.

Memory…:  This displays the debugger’s memory list at the position specified using the

temporary up cursor. If a memory list is already being displayed in an active

window, the contents of that window are updated at this point.

This has the same operation as clicking the  button.

Caution If there is no address information for the position specified using the temporary up cursor,

the items in the [Jump] menu cannot be selected.

(6) [Help] menu

File View Operation Browse Jump Help_ _ _ _ _ _

This Window_

Help Topics_

This Window:  This displays help topics about this window.

Help Topics:  This opens a dialog box for searching the AZ4000’s help contents (topics).

[Cautions]

• Data in this window is not automatically updated. Consequently, when re-executing an application program, in

order to have the newly collected trace data displayed in a state transition chart, select the upload function

(select [Operation] → [Upload] in the AZ4000 window).

• If there is no address information in the trace data for the position specified using the temporary up cursor, the

items in the [Jump] menu cannot be selected.

[Errors]

• An Error dialog box will appear if an active Analyze window already exists when attempting to change a

window from hold mode to active mode.

• An Error dialog box will appear if uploaded trace data does not include any task-level trace data.
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Object Select Dialog Box
[Object Select]

[General]

This dialog box is used to select or change the order of objects displayed in a state transition chart in a task-level

Analyze window.

This dialog box can be opened via any of the following operations.

• In the Analyze window, select [View] → [Select Object] on the menu bar.

• In the Analyze window, click the  button.

• In the Analyze window, press and hold the  Alt  key while pressing the  V  and  O  keys in that order.

[Window]

Figure 5-8.  Object Select Dialog Box

(a) Hide object area (b) Show object area

(c) Sort mode areas

[Functions]

The following items are described below.

(1) Description of areas

(2) Limitation of displayed objects

(3) Addition of displayed objects

(4) Changing order of displayed objects
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(1) Description of areas

(a) Hide object area

This area displays a list of objects contained in the AZ trace data that are not displayed in the state

transition chart.

(b) Show object area

This area displays a list of objects that are displayed in the state transition chart. The default setting is to

list all object names included in the AZ trace data.

The objects are listed in this area in the order that they appear in the state transition chart.

(c) Sort mode area

This area is used to select the order for listing objects in the <<hide object area>> and <<show object

area>>.

(2) Limitation of displayed objects

The objects displayed in the state transition chart can be limited (curtailed) via the following operations.

<1> Select objects from the show object area that do not need to be shown in the state transition chart.

<2> Click the  <<Hide  button. The selected object(s) will be moved to the hide object area. If a move

destination has been specified, the object(s) will be inserted immediately before that position. If a move

destination was not specified, the object(s) will be inserted at the end of the list.

<3> Click the  OK  button to update the state transition chart with these changes.

Remark Hidden objects are displayed collectively on the state transition chart as the object

.

(3) Addition of displayed objects

The objects displayed in the state transition chart can be added via the following operations.

<1> In the hide object area, select object(s) to be shown in the state transition chart.

<2> Click the  Show>>  button. The selected object(s) will be moved to the show object area. If a move

destination has been specified, the object(s) will be inserted immediately before that position. If a move

destination was not specified, the object(s) will be inserted at the end of the list.

<3> Click the  OK  button to update the state transition chart with these changes.

(4) Changing order of displayed objects

The order in which objects are listed in the hide object area and show object area can be set based on

interrupts, tasks, idle status, event flags, semaphores, mailboxes, and memory pools.

To change the listing order, select a sort mode from the sort mode area’s drop-down list.
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The listing order of show object area will be reflected in the state transition chart.

The selectable sort modes are listed below.

Sort Mode Description

None Unsorted mode (default)

Appear Sorts based on order of appearance in AZ trace data

Name Sorts based on names in each object type

ID Sorts based on IDs in each object type

[Function buttons]

Target Operation Button Function

Object This moves the object(s) selected in the show object area to the hide object area. If a

move destination has been specified, the object(s) will be inserted immediately

before that position. If a move destination was not specified, the object(s) will be

inserted at the end of the list.

Object This moves the selected object(s) in the hide object area to the show object area. If a

move destination has been specified, the object(s) will be inserted immediately

before that position. If a move destination was not specified, the object(s) will be

inserted at the end of the list.

− This displays objects in the state transition chart according to the list of objects in the

show object area.

− This closes this dialog box.

− This displays help topics about this dialog box.
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Pattern Search Dialog Box
[Pattern Search]

[General]

This dialog box is used to set search conditions when searching for “certain phenomena” in a state transition

chart.

The “certain phenomena” might be a specified task or interrupt, a point for switching to a specified task or

interrupt, or a condition for a specified service call.

This dialog box can be opened via any of the following operations.

• In the Analyze window, select [View] → [Search] on the menu bar.

• In the Analyze window, click the  button.

• In the Analyze window, press and hold the  Alt  key while pressing the  V  and  S  keys in that order.

[Window]

Figure 5-9.  Pattern Search Dialog Box (When Task Switch Is Selected)

(a) Search mode area (b) Search condition setting area
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[Functions]

The following items are described below.

(1) Description of areas

(2) Search methods

(1) Description of areas

(a) Search mode area

This area is used to select the search mode.

A search mode indicates the type of phenomena to be searched in a state transition chart. The available

search modes are listed below.

Table 5-3.  Pattern Search Modes

Search Mode Description

Task Switch Searches task switching locations

Service Call(Call) Searches locations of called service calls

Service Call(Return) Searches locations of returned service calls

Service Call(Error) Searches locations of service calls with returned errors

(b) Search condition setting area

This area is used to set search conditions for the search mode specified in the <<search mode area>>.

The contents displayed in this area differ according to the specified search mode.

Search conditions set for the items listed below can be directly input from the keyboard or can be

selected from a drop-down list.

The available conditions are listed below.

Table 5-4.  Pattern Search Conditions (When Search Mode Has Been Set to “Task Switch”)

Item Description of Condition

Task (upper) Specifies the task name or interrupt name prior to switching. Specify “ANY” if

any task or interrupt name can be used.

Task (lower) Specifies the task name or interrupt name after switching. Specify “ANY” if

any task or interrupt name can be used.

Interrupt Specifies whether or not to search for switches to or from interrupts.

Interrupt transitions are searched when “Valid” is selected and they are not

searched when “Invalid” is selected.
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Remark The difference in search positions for interrupt items according to the Valid/Invalid

specification are described below (when switching search condition from [ANY] to

[tsk(1002)]).

(a) (c)

Interrupt

(b)

tsk[1001]

tsk[1002]

Valid

Invalid

[(a) in above diagram]

Valid Search occurs when switching from [task1001] to [tsk1002]

Invalid Search occurs when switching from [task1001] to [tsk1002]

[(b) in above diagram]

Valid Search occurs when switching from [Interrupt] to [tsk1002]

Invalid Switching from interrupt servicing is ignored, but search occurs when switching from

[tsk1001] to [tsk1002]

[(c) in above diagram]

Valid Search occurs when switching from [Interrupt] to [tsk1002]

Invalid Switching from interrupt servicing is ignored, and is regarded as switching from [tsk1002] to

[tsk1002], so search does not occur since there was no switching.

Table 5-5.  Pattern Search Conditions

(When “Service Call(Call, Return, Error)” Has Been Specified as Search Mode)

Item Description of Condition

Task This specifies the task name or interrupt name for which a service call is

issued. Specify “ANY” if any task or interrupt name can be used.

Service Call This specifies the service call name. Specify “ANY” if any service call name

can be used.

Object This specifies the service call’s target object. Specify “ANY” if any object can

be used.
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(2) Search methods

[Operation method]

<1> Specify the position to be used as the search start position.

If the temporary up cursor is shown in the state transition chart, it is moved to the search start position.

If the temporary up cursor is not being displayed, the up cursor is moved to the search start position.

<2> Select a search mode in the search mode area of this dialog box.

<3> In the search condition setting area, directly enter a search condition for each item via the keyboard or

select search conditions from the drop-down list.

<4> Click the  button or the  button.

Searches are performed as described below.

•••• If the  button has been clicked:

The search is performed along the forward direction of the time axis, starting from the specified start

position, and the temporary up cursor is moved to the search results position.

•••• If the  button has been clicked:

The search is performed along the backward direction of the time axis, starting from the specified start

position, and the temporary up cursor is moved to the search results position.

[Function buttons]

Target Operation Button Function

Search condition Searches the state transition chart for locations that match the specified search

condition, moving along the forward direction of the time axis starting from the

position indicated by the up cursor or temporary up cursor. The temporary up cursor

is moved to the search results position in the state transition chart.

Search condition Searches the state transition chart for locations that match the specified search

condition, moving along the backward direction of the time axis starting from the

position indicated by the up cursor or temporary up cursor. The temporary up cursor

is moved to the search results position in the state transition chart.

− Closes this dialog box.

− Displays help topics about this dialog box.

[Errors]

A warning alarm is sounded if no phenomena that match the specified search condition exist in the AZ trace

data.
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CPU Window
[CPU Window]

[General]

This window displays CPU usage information for the time period between the up cursor and down cursor on the

state transition chart.

Use this window to check the execution time of a specified task or interrupt or to evaluate the performance of

target data based on idle time or interrupt time information.

This window can be opened via any of the following operations.

• In the Analyze window, select [Browse] → [CPU] on the menu bar.

• In the Analyze window, click the  button.

• In the Analyze window, press and hold the  Alt  key while pressing the  B  and  C  keys in that order.

[Window]

Figure 5-10.  CPU Window

(f)

(a)

(d)

(b) (c)

(e)(g)

(h)

(a) Time display at up cursor position (e) Object’s total execution time

(b) Time display at down cursor position (f) Graph display of CPU usage

(c) Time display between up and down cursors (g) Percentage display of task execution time

(d) Object name (h) Percentage display of system execution time



CHAPTER  5   WINDOW  REFERENCE

User’s Manual  U15031EJ1V0UM 57

[Functions]

The following items are described below.

(1) Description of areas

(2) CPU usage display method

(3) Jump function from CPU window

(1) Description of areas

(a) Time display at up cursor position

This displays the time when collection of CPU usage data began.

Relative time from the start of AZ trace data collection to the up cursor position is displayed here. The

unit of measurement is milliseconds (msec).

(b) Time display at down cursor position

This displays the time when collection of CPU usage data ended.

Relative time from the start of AZ trace data collection to the down cursor position is displayed here. The

unit of measurement is milliseconds (msec).

(c) Time display between up and down cursors

This displays the length of time used to collect CPU usage data.

The length of time between the up cursor and down cursor is displayed here. The unit of measurement

is milliseconds (msec).

(d) Object name

This is a list of object names that existed within the collected time.

(e) Object’s total execution time

The total task execution time for task or interrupts within the data collection time is displayed along with

the total system processing time.

(f) Graph display of CPU usage

A bar graph indicates the CPU usage for objects existing within the data collection time. The bars have

two sections, one indicating the task execution share and the other indicating the system processing

share.

(g) Percentage display of task execution time

The share of task execution time within the data collection time is shown as a percentage.

(h) Percentage display of system execution time

The share of system execution time within the data collection time is shown as a percentage.
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(2) CPU usage display method

The CPU usage data is collected during the time period between the up and down cursors in the state

transition chart.

[Operation method]

<1> Set the up cursor and down cursor to the positions in the state transition chart that mark the start and

end of the period for CPU usage data collection.

<2> Select [Browse] → [CPU] on the Analyze window’s menu bar to open this window.

Remark When the CPU window is open, the CPU usage data is automatically updated when the up cursor

or down cursor is moved to another location on the state transition chart.

(3) Jump function from CPU window

After using the mouse to specify an object in the list, select an item from the [Jump] menu to open the

following window.

•••• Pattern window

This window displays pattern distribution during the specified object’s processing time. The displayed

pattern is set automatically as described below.

Start point:  Task Switch from [ANY] to [Specified task]; [Valid]

End point:  Task Switch from [Specified task] to [ANY]; [Valid]

[Function buttons]

Target Operation Button Function

− This opens the File Select dialog box. The previously saved CPU window’s display

data is read and displayed.

− This opens the File Select dialog box. The data shown in the current CPU window is

saved to a file.

− This sorts the contents of the graph display according to order of appearance of trace

data.

− This sorts the contents of the graph display in alphabetical order of the object names.

− This sorts the contents of the graph display according to length of execution time.

− This sorts the contents of the graph display according to order of appearance in the

Analyze window.

Object This displays the Pattern window corresponding to the specified object. If an active

Pattern window is already being displayed, the contents of that window are updated

at this point.
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[Menu bar]

(1) [File] menu

File View Operation Jump Help_ _ _ _ _

Open..._

Save As..._

Print_

Close_

Open…:  This opens the File Select dialog box. A previously saved file displayed in this

window is loaded.

The default file name extension for files displayed in this window is “.azc”.

Save As…:  This opens the File Select dialog box. Currently displayed data is updated or

renamed and saved to a view file in this window.

The default file name extension for files displayed in this window is “.azc”.

Print:  This function is not supported in this version.

Close:  This closes this window.

Caution If a CPU usage graph is not being displayed, the [Save As...] menu item cannot be

selected.

(2) [View] menu

File View Operation Jump Help_ _ _ _ _

Sort Appear_

Sort Name_

Sort Time_

Sort Restore_

Sort Appear:  This sorts the contents of the graph display according to order of appearance of

AZ trace data.

This has the same operation as clicking the  button.

Sort Name:  This sorts the contents of the graph display according to the alphabetical order of

object names.

This has the same operation as clicking the  button.

Sort Time:  This sorts the contents of the graph display according to length of execution time

(default setting).

This has the same operation as clicking the  button.

Sort Restore:  This sorts the contents of the graph display according to the order of appearance

in the state transition chart.

This has the same operation as clicking the  button.
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(3) [Operation] menu

File View Operation Jump Help_ _ _ _ _

Active_

Hold_

Active:  This switches this window from hold mode to active mode.

Hold:  This switches this window from active mode to hold mode.

(4) [Jump] menu

File View Operation Jump Help_ _ _ _ _

Pattern..._

Pattern…: This window opens the Pattern window corresponding to the specified object. If an

active Pattern window is already being displayed, its contents are automatically

updated at this point.

The displayed pattern is set automatically as described below.

Start point:  Task Switch from [ANY] to [Specified object]; [Valid]

End point:  Task Switch from [Specified object] to [ANY]; [Valid]

This has the same operation as clicking the  button.

(5) [Help] menu

File View Operation Jump Help_ _ _ _ _

This Window_

Help Topics_

This Window:  This displays help topics about this window.

Help Topics:  This opens a dialog box for searching the AZ4000’s help contents (topics).

[Caution]

• This window is closed when the task-level Analyze window is closed.

[Errors]

• An Error dialog box will appear if an active CPU window already exists when attempting to change a window

from hold mode to active mode.
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Pattern Set Dialog Box
[Pattern Set]

[General]

This dialog box is used to set a pattern mode and pattern conditions as pattern settings to be displayed in the

Pattern window.

A pattern consists of events that occur between the time a certain event (task switch, interrupt, service call

condition, etc.) occurs and the time when that event ends, or that occur during the processing period (CPU

execution period) until another event occurs.

This dialog box can be opened via any of the following operations.

• In the Analyze window, select [Browse] → [Pattern] on the menu bar.

• In the Analyze window, click the  button.

• In the Analyze window, press and hold the  Alt  key while pressing the  B  and  P  keys in that order.

• In the Pattern window, select [Option] → [Pattern Set] on the menu bar.

• In the Pattern window, press and hold the  Alt  key while pressing the  P  and  S  keys in that order.

• In the Pattern window, click the  button.

[Window]

Figure 5-11.  Pattern Set Dialog Box (When Task Switch Is Selected)

(a) Pattern search mode area

(b) Search condition setting area

Caution The items displayed in the <<search condition setting area>> differ according to what has been

selected in the pattern search mode area.
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[Functions]

The following items are described below.

(1) Description of areas

(2) Pattern search/tabulation methods

(1) Description of areas

(a) Pattern search mode area

This area is used to select the pattern mode.

A pattern mode indicates the type of event to be tabulated between the start (From:) and end (To:)

points in the Pattern window.

The available pattern modes are listed below.

Table 5-6.  Pattern Modes

Pattern Mode Description

Task Switch Uses task switching locations as start and end points

Service Call(Call) Uses locations of called service calls as start and end points

Service Call(Return) Uses locations of returned service calls as start and end points

Service Call(Error) Uses locations of service calls with returned errors as start and end

points

(b) Search condition setting area

This area is used to set search conditions for the pattern mode specified in the pattern search mode

area (a).

The contents displayed in this area differ according to the specified pattern mode.

Search conditions set for the items listed below can be directly input from the keyboard or can be

selected from a drop-down list.

The available conditions are listed below.

Table 5-7.  Pattern Search Conditions (When Search Mode Has Been Set to “Task Switch”)

Item Description of Condition

Task (upper) Specifies the task name or interrupt name prior to switching. Specify “ANY” if

any task or interrupt name can be used.

Task (lower) Specifies the task name or interrupt name after switching. Specify “ANY” if

any task or interrupt name can be used.

Interrupt Specifies whether or not to search for switches to or from interrupts.

Interrupt transitions are searched when “Valid” is selected and they are not

searched when “Invalid” is selected.
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Remark The difference in search positions for interrupt items according to the Valid/Invalid

specification are described below.

(a)

(c)

Interrupt

(b)

tsk1001

tsk1002

Valid

Invalid

tsk1003

Search condition From: [ANY] → [tsk1002]
To: [tsk1002] → [ANY]

When “Valid” has been specified:

Events during (a) and (b) are detected as a pattern since an interrupt was detected as a target for

switching.

When “Invalid” has been specified:

Events during (c) are detected as a pattern since no interrupt was detected as a target for switching.

In this case, the time of the interrupt’s appearance is used to calculate the pattern’s start and end times

and the interrupt time is included in the pattern’s execution time.

Table 5-8.  Pattern Search Conditions

(When “Service Call(Call, Return, Error)” Has Been Specified as Search Mode)

Item Description of Condition

Task This specifies the task name or interrupt name for which a service call is

issued. Specify “ANY” if any task or interrupt name can be used.

Service Call This specifies the service call name. Specify “ANY” if any service call name

can be used.

Object This specifies the service call’s target object. Specify “ANY” if any object can

be used.
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Remark The following are some typical pattern settings.

[Analysis of interrupt servicing time]

From: Task Switch  [ANY]→[INTP10];[Valid]

To: Task Switch  [INTP10]→[ANY];[Valid]

[Analysis of service call processing time] (analysis of processing time between wai_sem

service call issued by tsk(1001) and acquisition of resources from sem(1000))

From: Service Call(Call) [tsk(1001)]→[wai_sem];[sem(1000)]

To: Service Call(Return)  [tsk(1001)]→[wai_sem];[sem(1000)]

[Analysis of processing time between issuance of service call and wake of other task]

(analysis of processing time between slp_tsk issued by tsk(1001) and passing of processing to

tsk(1002))

From: Service Call(Call)  [tsk(1001)]→[slp_tsk]

To: Task Switch [ANY]→[tsk(1002)]

[Analysis of error return interval] (analysis of interval between locations where error is returned

for tsk(1001))

From: Service Call(Error)  [tsk(1001)]→[ANY];[ANY]

To: Service Call(Error)  [tsk(1001)]→[ANY];[ANY]

(2) Pattern search/tabulation methods

Perform the following operations to search and tabulate a previously set pattern in a specified area and to

open the Pattern window.

[Operation method]

<1> On the state transition chart, set the up cursor and down cursor to define the pattern distribution area to

be tabulated. This dialog box will then appear.

<2> In the “From:” area, select the pattern mode for the start point of the pattern to be tabulated.

<3> In the “To:” area, select the pattern mode for the end point of the pattern to be tabulated.

<4> In the <<search condition setting area>>, enter pattern search conditions for the “From:” and “To:”

items, either by directly inputting them via the keyboard or by selecting them from a drop-down list.

<5> Click the  OK  button.

[Function buttons]

Target Operation Button Function

Pattern search

condition

Searches and tabulates the previously set pattern in the state transition chart for the

time range between the up cursor and down cursor, then opens the Pattern window.

− Closes this dialog box.

− Displays help topics about this dialog box.

[Errors]

• An Error dialog box appears if the AZ trace data does not include any patterns that meet the previously set

search conditions.
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Pattern Window
[Pattern Window]

[General]

In this window, a pattern that has been set via the Pattern Set dialog box as within the time range between the up

and down cursors on the state transition chart is searched, and the appearance of the pattern is tabulated based

on the execution time period and is displayed on a histogram.

A pattern consists of events that occur between the time a certain event (task switch, interrupt, service call

condition, etc.) occurs and the time when that event ends, or that occur during the processing period (CPU

execution period) until another event occurs.

This window can be used to obtain worst-case values, average values, or other values for the execution time of

processing in any user program.

This window can be opened via any of the following operations.

• In the Analyze window, select [Browse] → [Pattern] on the menu bar, then set conditions via the Pattern Set

dialog box.

• In the Analyze window, click the  button, then set conditions via the Pattern Set dialog box.

• In the Analyze window, press and hold the  Alt  key while pressing the  B  and  P  keys in that order, then set

conditions via the Pattern Set dialog box.

• In the CPU window, select [Jump] → [Pattern] on the menu bar.

• In the CPU window, click the  button.
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[Window]

Figure 5-12.  Pattern Window

(b) (c)

(h)

(a) (e)

(g)

(d) (f)

(a) Time display at up cursor position (e) Average value display

(b) Time display at down cursor position (f) Histogram divisor display

(c) Time display between up and down cursors (g) Processing time view area

(d) Pattern condition display (h) Pattern distribution view area

[Functions]

The following items are described below.

(1) Description of areas

(2) Pattern display method

(3) How to read patterns

(4) Searching from the Pattern window

(1) Description of areas

(a) Time display at up cursor position

This displays the time when tabulation of pattern distribution began.

Relative time from the start of AZ trace data collection to the up cursor position is displayed in the state

transition chart. The unit of measurement is milliseconds (msec).

(b) Time display at down cursor position

This displays the time when tabulation of pattern distribution ended.

Relative time from the start of AZ trace data collection to the down cursor position is displayed in the

state transition chart. The unit of measurement is milliseconds (msec).



CHAPTER  5   WINDOW  REFERENCE

User’s Manual  U15031EJ1V0UM 67

(c) Time display between up and down cursors

This displays the length of time used to tabulate pattern data.

The length of time between the up cursor and down cursor is displayed here. The unit of measurement

is milliseconds (msec).

(d) Pattern condition display

This displays the pattern conditions that were set via the Pattern Set dialog box.

(e) Average value display

This displays an average value of the previously set pattern’s execution time. The unit of measurement

is milliseconds (msec).

(f) Histogram divisor display

This displays the histogram divisor. The divisor value can be set in a range from 1 to 100 by clicking the

up and down buttons to the right of this display.

(g) Processing time view area

This displays the length of time required for processing of the previously set pattern.

(h) Pattern distribution view area

This displays a histogram of the tabulation results for the previously set pattern’s processing time in the

period between the up and down cursors on the state transition chart.

(2) Pattern display method

Patterns are tabulated within the period between the up and down cursors on the state transition chart.

[Operation methods]

<1> In the state transition chart, set the up cursor and down cursor to demarcate the section in which

pattern data is to be tabulated.

<2> In the Analyze window, select [Browse] → [Pattern] on the menu bar.

<3> In the Pattern Set dialog box (which opens automatically), set the conditions for the pattern to be

tabulated and displayed, then click the  OK  button.

Remark If the up cursor or down cursor is moved in the state transition chart while the Pattern window is

open, the pattern display is automatically updated.
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(3) How to read patterns

Figure 5-13 shows an example of a pattern used for analysis of Tsk[0002]’s processing time.

Figure 5-13.  How to Read Patterns

This indicates that Tsk[0002]'s average processing time 
is 0.059 ms.

This indicates Tsk[0002]'s execution time period, obtained 
by dividing the maximum and minimum times by the 
specified divisor.

This indicates that processing of Tsk[0002] occurred at 
20 locations within the time period of 0.012651 ms to 
0.096561 ms.

(4) Searching from the Pattern window

The “function buttons” in the Pattern window are used to search the maximum and minimum execution time

(or ascending order of time periods) in the processing time for the previously set pattern. The search results

are displayed in a state transition chart in this window.

The temporary up cursor is moved to the start position of the searched pattern and the temporary down

cursor is moved to the end position.

[Function buttons]

Target Operation Button Function

− This opens the File Select dialog box. The previously saved Pattern window’s display

data is read and displayed.

− This opens the File Select dialog box. The data shown in the current Pattern window

is saved to a file.

− This opens the Pattern Set dialog box.

− This displays the location of the minimum execution time period in the searched

pattern in the Analyze window.

− This searches for the location with the next-shortest execution time period compared

to the currently searched location.

− This searches for the location with the next-longest execution time period compared

to the currently searched location.

− This displays the location of the maximum execution time period in the searched

pattern in the Analyze window.
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[Menu bar]

(1) [File] menu

File View OperationOption Help_ _ __ _

Open..._

Save As..._

Print_

Close_

Open…:  This opens the File Select dialog box. A previously saved file displayed in this

window is loaded.

The default file name extension for files displayed in this window is “.azp”.

Save As…:  This opens the File Select dialog box. Currently displayed data in this window is

updated or renamed and saved to a view file in this window.

The default file name extension for files displayed in this window is “.azp”.

Print:  This function is not supported in this version.

Close:  This closes this window.

(2) [View] menu

File View OperationOption Help_ _ __ _

Divide(+)(I)_

Divide(−)(D)_

Divide(+)(I):  This increments (by one) the histogram’s divisor.

Divide(−)(D):  This decrements (by one) the histogram’s divisor.

(3) [Option] menu

File View OperationOption Help_ _ __ _

Pattern Set..._

Pattern Set…: This opens this window’s trace-level Pattern Set dialog box.
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(4) [Operation] menu

File View OperationOption Help_ _ __ _

Active_

Hold_

Search (Min)_

Search (Max)_

Search (Fore)_

Search (Back)_

Active:  This switches this window from hold mode to active mode.

Hold: This switches this window from active mode to hold mode.

Search (Min):  The location of the shortest execution time in the tabulated pattern is displayed in

the state transition chart.

The temporary up cursor is moved to the start position of the searched pattern and

the temporary down cursor is moved to the end position.

This has the same operation as clicking the  button.

Search (Max):  The location of the longest execution time in the tabulated pattern is displayed in

the state transition chart.

The temporary up cursor is moved to the start position of the searched pattern and

the temporary down cursor is moved to the end position.

This has the same operation as clicking the  button.

Search (Fore):  After [Search (Min)] has been selected or the  button has been clicked, the

location with the next-shortest execution time period compared to the currently

searched location is searched.

The temporary up cursor is moved to the start position of the searched pattern and

the temporary down cursor is moved to the end position.

This has the same operation as clicking the  button.

Search (Back):  After [Search (Max)] has been selected or the  button has been clicked, the

location with the next-longest execution time period compared to the currently

searched location is searched.

The temporary up cursor is moved to the start position of the searched pattern and

the temporary down cursor is moved to the end position.

This has the same operation as clicking the  button.

(5) [Help] menu

File View Operation Jump Help_ _ _ _ _

This Window_

Help Topics_

This Window:  This displays help topics about this window.

Help Topics:  This opens a dialog box for searching the AZ4000’s help contents (topics).
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[Caution]

• The Pattern window is closed when the Analyze window is closed.

[Errors]

• An Error dialog box will appear if an active Pattern window already exists when attempting to change a window

from hold mode to active mode.
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Trace View Window
[Trace View Window]

[General]

This window displays a list of the AZ trace data that is shown in a state transition chart.

When this window is opened from the Analyze window, it can be used for detailed checking of AZ trace data.

This window can be opened via any of the following operations.

• In the Analyze window, select [Browse] → [Trace View] on the menu bar.

• In the Analyze window, click the  button.

• In the Analyze window, press and hold the  Alt  key while pressing the  B  and  T  keys in that order.

[Window]

Figure 5-14.  Trace View Window

(b) (c)(a) (d) (e) (f)

(a) Time view area (d) Event view area

(b) Address view area (e) Parameter view area

(c) Task view area (f) Return view area

[Functions]

The following items are described below.

(1) Description of areas

(2) AZ trace data display method

(3) How to read AZ trace data

(4) AZ trace data search method

(1) Description of areas

(a) Time view area

This area shows the relative time from the start of the AZ trace. The unit is milliseconds (msec).



CHAPTER  5   WINDOW  REFERENCE

User’s Manual  U15031EJ1V0UM 73

(b) Address view area

This area shows the user program’s execution address. This address is the start address of the next

instruction after the actual event occurred.

(c) Task view area

This area shows the task or interrupt name for each event.

(d) Event view area

This area shows the types of events in the AZ trace data. These event types are listed below.

•••• ServiceCall

This indicates a service call. The name of the service call is shown in parentheses.

•••• ServiceRet

This indicates a returned service call. The name of the returned service call is shown in parentheses.

•••• Int

This indicates the start of an interrupt. The name of the interrupt request is shown in parentheses.

•••• IntRet

This indicates the end of an interrupt. The name of the interrupt request is shown in parentheses.

•••• TaskStart

This indicates a task’s initial start.

•••• Idle

This indicates a switch to idle mode.

(e) Parameter view area

If the AZ trace data is a service call, this indicates the service call’s target object.

(f) Return view area

If the AZ trace data is a returned service call, this indicates the service call’s return value.

(2) AZ trace data display method

The AZ trace data is shown at the specified position on the state transition chart.

[Operation methods]

<1> Specify the view start position for the AZ trace data.

If a temporary up cursor is displayed on the state transition chart, the temporary up cursor marks the

view start position. If it is not shown, the start of the trace data marks the view start position.

<2> In the Analyze window, select [Browse] → [Trace View] on the menu bar to open this window.

Remark If the temporary up cursor is moved in the state transition chart while the Trace View window is

open, the AZ trace data’s view position is automatically updated.
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(3) How to read AZ trace data

Figure 5-15 presents a guide for reading AZ trace data.

Figure 5-15.  How to Read AZ Trace Data

(a)

(b)

(a) This indicates that 1.009 ms after the system was started, the service call “sta_tsk” was issued at

address 0x800131b0 by the task “Tsk(0002)” for the task “Tsk(0003)”.

(b) This indicates that 1.011 ms after the system was started, the value “E_OK” was returned in relation to

service call “sta_tsk” at address 0x80013b0.

For details of returned values, see the RX4000 User’s Manual.

Remark For “ServiceRet”, if the corresponding service call event does not exist in the trace memory, a

blank space will be shown between the parentheses. This can happen when the service call is

executed from within a user program.

(4) AZ trace data search method

The Trace Search dialog box, which can be opened via this window’s menu bar, can be used to search

conditions such as execution task names, interrupt names, event types, or service call arguments.

For details of the search method, see the description of the Trace Search dialog box.

[Operation methods]

<1> Select [View] → [Search] via this window’s menu bar.

<2> Set the search conditions in the Trace Search dialog box that appears automatically.

<3> Click the  button in the Trace Search dialog box to start searching in the direction of

newer trace times, or click the  button in the Trace Search dialog box to start searching

in the direction of older trace times.

<4> Update the AZ trace data view position at the start of the searched location.
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[Menu bar]

(1) [File] menu

File Edit Operation Help_ _ _ _

Open..._

Save As..._

Print_

Close_

View_

Open…:  This function is not supported in this version.

Save As…:  This opens the File Select dialog box. Currently displayed data in this window is

updated or renamed and saved to a view file in this window.

The default file name extension for files displayed in this window is “.azt”.

Print:  This function is not supported in this version.

Close:  This closes this window.

(2) [Edit] menu

File Edit Operation Help_ _ _ _

Copy_

View_

Copy:  This function is not supported in this version.

(3) [View] menu

File Edit Operation Help_ _ _ _View_

Timetag_

Address_

Task_
Show_

Hide_

Search..._

Event_

Parameter_
Return_

Search…:  This opens the Trace Search dialog box.

Timetag:  This specifies show or hide mode for the “Time” item.

Select [Show] or [Hide] from the sub menu.

Address:  This specifies show or hide mode for the “Address” item.

Select [Show] or [Hide] from the sub menu.

Task:  This specifies show or hide mode for the “Task” item.

Select [Show] or [Hide] from the sub menu.

Event:  This specifies show or hide mode for the “Event” item.

Select [Show] or [Hide] from the sub menu.
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Parameter: This specifies show or hide mode for the “Parameter” item.

Select [Show] or [Hide] from the sub menu.

Return:  This specifies show or hide mode for the “Return” item.

Select [Show] or [Hide] from the sub menu.

(4) [Operation] menu

File Edit Operation Help_ _ _ _View_

Active_

Hold_

Active:  This switches this window from hold mode to active mode.

Hold:  This switches this window from active mode to hold mode.

(5) [Help] menu

File Edit Operation Help_ _ _ _View_

This Window_

Help Topics_

This Window:  This displays help topics about this window.

Help Topics:  This opens a dialog box for searching the AZ4000’s help contents (topics).

[Cautions]

• This window is closed when the Analyze window is closed.

• For “ServiceRet”, if the corresponding service call event does not exist in the trace buffer, a blank space will be

shown between the parentheses. This can happen when the service call is executed from within a user

program.

[Errors]

• An Error dialog box will appear if an active Trace View window already exists when attempting to change a

window from hold mode to active mode.
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Trace Search Dialog Box
[Trace Search]

[General]

This dialog box is used to set search conditions before searching AZ trace data via the Trace View window.

The search conditions that can be set include execution task names, interrupt names, event types, or service call

arguments.

This dialog box can be opened via any of the following operations.

• In the Trace View window, select [View] → [Search] on the menu bar.

• In the Trace View window, press and hold the  Alt  key while pressing the  V  and  S  keys in that order.

[Window]

Figure 5-16.  Trace Search Dialog Box

(a) Search data setting area (b) Search condition setting area

[Functions]

The following items are described below.

(1) Description of areas

(2) Search methods

(1) Description of areas

(a) Search data setting area

This area is used to specify search items in the AZ trace data shown in the Trace View window.

Select the check box next to the desired search item. Several items can be selected.

Task:  Select this when searching task names or interrupt names.

Event:  Select this when searching event types.

Parameter:  Select this when searching service call arguments.
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(b) Search condition setting area

This area is used to specify search conditions for each search item.

From each drop-down list, select a task name, interrupt name, event type, or service call argument that

exists in the collected AZ trace data.

(2) Search methods

[Operation methods]

<1> In the <<search data setting area>>, select the target item to be searched. Several items can be

selected.

<2> Search conditions in the <<search condition setting area>> can be directly input from the keyboard or

can be selected from a drop-down list.

<3> Click the  button or the  button.

Searches are performed as described below.

• If the  button has been clicked:

A search of locations that match the previously set search conditions is performed in the direction of newer

trace times, and the Trace View window is displayed starting at the first search location.

• If the  button has been clicked:

A search of locations that match the previously set search conditions is performed in the direction of older

trace times, and the Trace View window is displayed starting at the first search location.

The following are some examples of search condition settings in the Trace Search dialog box.

Figure 5-17.  Example of Trace Search Settings (When Searching for Task “Tsk(1001)”)
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Figure 5-18.  Example of Trace Search Settings (When Task “Tsk(1001)” Searches for Location Where Service

Call “sta_tsk” Was Issued)

Figure 5-19.  Example of Trace Search Settings (When Task “Tsk(1001)” Searches for Location Where Service

Call “sta_tsk” Was Issued for Task “Tsk(1002)”)

[Function buttons]

Target Operation Button Function

Search condition Locations matching the previously set search conditions are searched in the direction

of newer trace times, and the Trace View window is displayed starting at the first

search location.

Search condition Locations matching the previously set search conditions are searched in the direction

of older trace times, and the Trace View window is displayed starting at the first

search location.

− Closes this dialog box.

− Displays help topics about this dialog box.

[Errors]

• A warning alarm is sounded if no phenomena that match the specified search condition exist in the AZ trace

data.

• A warning alarm is sounded if the  or  button has been clicked without first

selecting at least one item from the <<search data setting area>>.
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File Select Dialog Box
[File Open]

[General]

This dialog box is used to select a view file to be loaded or saved.

This dialog box can be opened via any of the following operations.

• In any window, select [File] → [Open] on the menu bar.

• In any window, select [File] → [Save As] on the menu bar.

• In any window, click the  button.

• In any window, click the  button.

• In any window, click the  Alt  key while pressing the  F  and  O  keys in that order.

• In any window, click the  Alt  key while pressing the  F  and  A  keys in that order.

[Window]

Figure 5-20.  File Select Dialog Box
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[Functions]

The following items are described below.

(1) View file extensions and file formats

(2) Retrieval of view information

(1) View file extensions and file formats

View file types vary according to the window being used, and the various types can be identified by their file

name extensions.

The default extensions used for different types of view files used in various AZ4000 windows are listed in

Table 5-9 below.

Table 5-9.  View File Types and Extensions

View File Type Extension File Format

Analyze window .AZ Binary format

CPU window .AZC

Pattern window .AZP

Trace View window .AZT

CSV format

(2) Retrieval of view information

The way that view information is retrieved by loading a view file differs according to the window, as described

below.

(a) Analyze window

View information is retrieved into the currently open Analyze window.

Consequently, to retain the currently displayed state transition chart, set the currently open Analyze

window to “hold” mode, then open a new Analyze window and load a view file.

(b) Other windows

A new window is opened in “hold mode” and the view information is retrieved into that window.

Consequently, the open window’s view information is retained as it is on the screen.

[Function buttons]

Target Operation Button Function

Select file Loads or saves the selected view file.

− Closes this dialog box.

− Displays help topics about this dialog box (this button is displayed only when the

AZ4000’s help file has been installed).
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[Errors]

• An Error dialog box appears if the specified file name’s format is incorrect.

• An Error dialog box appears if an attempt is made to load a non-existent file.

• An Error dialog box appears if an attempt is made to save a write-protected file.

• An overwrite warning message appears if an attempt is made to save a new file with the same name as an

older file.

• An Error dialog box appears if an attempt is made to load data that cannot be handled by the current window.
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APPENDIX  A   ERROR  MESSAGES

The AZ4000’s error messages are listed using the following format.

Error messageError No.

Action by user

(1/2)

Not enough memory.1000

There is not enough available memory on the machine. Close unnecessary windows, then retry execution.

Internal error.1001

An unexpected error has occurred. Retry execution from the start.

Can't change to active mode.1010

Another window is already open in active mode, so this window cannot be changed to active mode. Either

change the other (active) window to hold mode or close it, then change this window to active mode.

Illegal file name.1020

An illegal character, character string, or format was used in a file name. Check the file name and retry execution.

Not exist file.1021

The specified file name does not exist. Specify a valid file name.

Can't write file.1022

Cannot write to file, either due to a lack of disk space or because the target file is a read-only file. Specify a file

on another disk or a file that is not a read-only file.

Illegal file format.1023

The target file does not have the correct format and therefore cannot be read. Check the file’s contents.

Not implement AZ interface.1100

Cannot connect to debugger because the AZ interface has not been implemented on the debugger. Confirm that

the debugger is TIP-compliant.

Can't switch trace mode.1110

An error occurred during AZ trace ON/OFF switching. Data in the RX4000 or AZ monitor may have been

corrupted.

Either reload the load module or restart the debugger and the AZ4000.

Not specified trace buffer region.1118

AZ trace ON is set in a state where the trace buffer region is not specified. In the AZ Option dialog box, specify a

trace buffer region, then set AZ trace ON.

Can't upload.1120

An error occurred during processing to upload trace data. The trace memory region setting may be incorrect.

Confirm whether or not correct addresses were specified for the trace memory region. Also, make sure that the

memory information addresses specified during configuration of the RTOS do not overlap with the AZ monitor’s

region.

No trace data.1121

The executed data does not include any trace data.

Set AZ trace ON again, then execute the user program and upload trace data.
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(2/2)

Illegal trace data.1122

The time tag in the trace data may be incorrect.

Make sure that the user’s own coding block has been coded correctly.

Illegal trace buffer address.1210

Address range specified by trace buffer region specification is not correct.

Specify a correct address range for the trace buffer region.

Not exist pattern.1400

The specified pattern does not exist in the trace data between the up cursor and down cursor. Extend the width

between the up and down cursors and retry execution. If this error occurs even when the maximum width has

been set, the specified pattern does not exist at all in the trace data.
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Addition.................................................................50
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